re = /\d(m)"/m
str = '{
"test1": ["300m","50m","0","4","1050m"],
"test2": ["600m","400m","10m","0","2"],
...
}'
subst = '000'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result