import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d(m)\"";
final String string = "{\n"
+ "\"test1\": [\"300m\",\"50m\",\"0\",\"4\",\"1050m\"],\n"
+ "\"test2\": [\"600m\",\"400m\",\"10m\",\"0\",\"2\"],\n"
+ "...\n"
+ "}";
final String subst = "000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}