import Foundation
let pattern = #"\d(m)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"test1": ["300m","50m","0","4","1050m"],
"test2": ["600m","400m","10m","0","2"],
...
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"000"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)