# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d(m)\""
test_str = ("{\n"
"\"test1\": [\"300m\",\"50m\",\"0\",\"4\",\"1050m\"],\n"
"\"test2\": [\"600m\",\"400m\",\"10m\",\"0\",\"2\"],\n"
"...\n"
"}")
subst = "000"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.