const regex = /\d(m)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d(m)"', 'gm')
const str = `{
"test1": ["300m","50m","0","4","1050m"],
"test2": ["600m","400m","10m","0","2"],
...
}`;
const subst = `000`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);