#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d(m)""
Local $sString = "{" & @CRLF & _
""test1": ["300m","50m","0","4","1050m"]," & @CRLF & _
""test2": ["600m","400m","10m","0","2"]," & @CRLF & _
"..." & @CRLF & _
"}"
Local $sSubst = "000"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)