# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[ \t]*([\w.]+) => ([\w.]+)[, ]*/[TestCase($1, $2)]/gm;t' <<< "Proto.Regime.Commercial => Regime.Commercial,
Proto.Regime.Economic => Regime.Economic,
Proto.Regime.Fiscal => Regime.Fiscal,
Proto.Regime.Generic => Regime.Generic,"