import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ \\t]*([\\w.]+) => ([\\w.]+)[, ]*";
final String string = "Proto.Regime.Commercial => Regime.Commercial,\n"
+ " Proto.Regime.Economic => Regime.Economic,\n"
+ " Proto.Regime.Fiscal => Regime.Fiscal,\n"
+ " Proto.Regime.Generic => Regime.Generic,";
final String subst = "[TestCase($1, $2)]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}