// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[ \t]*([\w.]+) => ([\w.]+)[, ]*").unwrap();
let string = "Proto.Regime.Commercial => Regime.Commercial,
Proto.Regime.Economic => Regime.Economic,
Proto.Regime.Fiscal => Regime.Fiscal,
Proto.Regime.Generic => Regime.Generic,";
let substitution = "[TestCase($1, $2)]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}