use strict;
my $str = 'Proto.Regime.Commercial => Regime.Commercial,
Proto.Regime.Economic => Regime.Economic,
Proto.Regime.Fiscal => Regime.Fiscal,
Proto.Regime.Generic => Regime.Generic,';
my $regex = qr/[ \t]*([\w.]+) => ([\w.]+)[, ]*/mp;
my $subst = '[TestCase($1, $2)]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";