package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ \t]*([\w.]+) => ([\w.]+)[, ]*`)
var str = `Proto.Regime.Commercial => Regime.Commercial,
Proto.Regime.Economic => Regime.Economic,
Proto.Regime.Fiscal => Regime.Fiscal,
Proto.Regime.Generic => Regime.Generic,`
var substitution = "[TestCase($1, $2)]"
fmt.Println(re.ReplaceAllString(str, substitution))
}