import Foundation
let pattern = #"[ \t]*([\w.]+) => ([\w.]+)[, ]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Proto.Regime.Commercial => Regime.Commercial,
Proto.Regime.Economic => Regime.Economic,
Proto.Regime.Fiscal => Regime.Fiscal,
Proto.Regime.Generic => Regime.Generic,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[TestCase($1, $2)]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)