#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)work\/^(admin)"
Local $sString = "да http://url.ru/work/guest_del" & @CRLF & _
"да http://url.ru/work/big/del" & @CRLF & _
"нет http://url.ru/work/admin" & @CRLF & _
"нет http://url.ru/work/admin/guest_del"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")