using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"work\/^(admin)";
string input = @"да http://url.ru/work/guest_del
да http://url.ru/work/big/del
нет http://url.ru/work/admin
нет http://url.ru/work/admin/guest_del";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}