$re = '/work\/^(admin)/m';
$str = 'да http://url.ru/work/guest_del
да http://url.ru/work/big/del
нет http://url.ru/work/admin
нет http://url.ru/work/admin/guest_del';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);