re = /work\/^(admin)/m
str = 'да http://url.ru/work/guest_del
да http://url.ru/work/big/del
нет http://url.ru/work/admin
нет http://url.ru/work/admin/guest_del'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end