package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)work\/^(admin)`)
var str = `да http://url.ru/work/guest_del
да http://url.ru/work/big/del
нет http://url.ru/work/admin
нет http://url.ru/work/admin/guest_del`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}