import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "work\\/^(admin)";
final String string = "да http://url.ru/work/guest_del\n"
+ "да http://url.ru/work/big/del\n"
+ "нет http://url.ru/work/admin\n"
+ "нет http://url.ru/work/admin/guest_del";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}