#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[\w +\.,#\u00E0-\u00FC\-\:\%\€\@\§\!]+$"
Local $sString = "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle+,._-%@:§€!aasd" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE + aperçu FileTitle+" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE , aperçu FileTitle," & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE . aperçu FileTitle." & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle#" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle_" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle-" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle%" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle@" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle:" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle§" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle€" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle!" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle;" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitleµ" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle$" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle"" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle(" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle)" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle=" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle?" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle`" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle´" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle'" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle*" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle~" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle^" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle°" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle<" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle>" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle|" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE / aperçu FileTitle" & @CRLF & _
"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE \ aperçu FileTitle"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")