const regex = /^[\w +\.,#\u00E0-\u00FC\-\:\%\€\@\§\!]+$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w +\\.,#\\u00E0-\\u00FC\\-\\:\\%\\€\\@\\§\\!]+$', 'img')
const str = `abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle+,._-%@:§€!aasd
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE + aperçu FileTitle+
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE , aperçu FileTitle,
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE . aperçu FileTitle.
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle#
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle_
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle-
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle%
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle@
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle:
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle§
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle€
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle!
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle;
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitleµ
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle\$
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle"
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle(
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle)
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle=
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle?
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle\`
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle´
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle'
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle*
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle~
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle^
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle°
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle<
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle>
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle|
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE / aperçu FileTitle
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE \\ aperçu FileTitle`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}