use strict;
my $str = 'abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle+,._-%@:§€!aasd
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE + aperçu FileTitle+
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE , aperçu FileTitle,
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE . aperçu FileTitle.
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle#
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle_
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle-
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle%
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle@
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle:
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle§
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle€
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle!
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle;
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitleµ
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle$
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle"
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle(
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle)
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle=
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle?
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle`
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle´
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle\'
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle*
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle~
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle^
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle°
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle<
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle>
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle|
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE / aperçu FileTitle
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE \\ aperçu FileTitle';
my $regex = qr/^[\w +\.,#\u00E0-\u00FC\-\:\%\€\@\§\!]+$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}