import Foundation
let pattern = ##"^[\w +\.,#\u00E0-\u00FC\-\:\%\€\@\§\!]+$"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle+,._-%@:§€!aasd
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE + aperçu FileTitle+
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE , aperçu FileTitle,
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE . aperçu FileTitle.
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle#
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle_
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle-
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle%
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle@
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle:
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle§
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle€
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle!
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle;
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitleµ
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle$
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle"
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle(
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle)
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle=
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle?
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle`
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle´
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle'
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle*
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle~
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle^
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle°
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle<
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle>
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle|
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE / aperçu FileTitle
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE \ aperçu FileTitle
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)