using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w +\.,#\u00E0-\u00FC\-\:\%\€\@\§\!]+$";
string input = @"abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle+,._-%@:§€!aasd
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE + aperçu FileTitle+
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE , aperçu FileTitle,
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE . aperçu FileTitle.
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle#
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle_
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle-
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle%
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle@
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle:
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle§
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle€
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle!
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle;
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitleµ
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle$
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle""
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle(
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle)
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle=
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle?
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle`
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle´
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle'
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle*
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle~
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle^
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle°
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle<
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle>
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle|
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE / aperçu FileTitle
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE \ aperçu FileTitle";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}