re = /^[\w +\.,#\u00E0-\u00FC\-\:\%\€\@\§\!]+$/im
str = 'abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle+,._-%@:§€!aasd
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE + aperçu FileTitle+
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE , aperçu FileTitle,
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE . aperçu FileTitle.
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle#
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle_
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle-
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle%
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle@
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle:
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle§
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle€
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle!
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle;
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitleµ
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle$
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle"
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle(
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle)
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle=
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle?
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle`
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle´
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle\'
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle*
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle~
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle^
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle°
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle<
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle>
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle|
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE / aperçu FileTitle
abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE \\ aperçu FileTitle'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end