import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w +\\.,#\\u00E0-\\u00FC\\-\\:\\%\\€\\@\\§\\!]+$";
final String string = "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle+,._-%@:§€!aasd\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE + aperçu FileTitle+\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE , aperçu FileTitle,\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE . aperçu FileTitle.\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle#\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle_\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle-\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle%\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle@\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle:\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle§\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle€\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle!\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle;\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitleµ\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle$\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle\"\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle(\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle)\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle=\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle?\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle`\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle´\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle'\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle*\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle~\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle^\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle°\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle<\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle>\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE aperçu FileTitle|\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE / aperçu FileTitle\n"
+ "abcdefghiopöäüascel2ql3ÄÖÜ à geWEGE \\ aperçu FileTitle";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}