#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(?:\(\d{3}\)\s*|\d{3})-?\d{3}-?\d{4}\s*$"
Local $sString = "(404) 666-1111" & @CRLF & _
"(404) 6661111" & @CRLF & _
"404-666-1111" & @CRLF & _
"404-6661111" & @CRLF & _
"404666-1111" & @CRLF & _
"4046661111" & @CRLF & _
" (404) 666-1111 " & @CRLF & _
"(404)666-1111 " & @CRLF & _
" 404-666-1111 " & @CRLF & _
" 404-6661111 " & @CRLF & _
" 4046661111" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"+1 (404) 666-1111" & @CRLF & _
" ( 404)666-1111" & @CRLF & _
"404.666.1111" & @CRLF & _
"404 666-1111" & @CRLF & _
"404 666 1111" & @CRLF & _
"(404-666-1111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")