re = /^\s*(?:\(\d{3}\)\s*|\d{3})-?\d{3}-?\d{4}\s*$/m
str = '(404) 666-1111
(404) 6661111
404-666-1111
404-6661111
404666-1111
4046661111
(404) 666-1111
(404)666-1111
404-666-1111
404-6661111
4046661111
+1 (404) 666-1111
( 404)666-1111
404.666.1111
404 666-1111
404 666 1111
(404-666-1111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end