package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(?:\(\d{3}\)\s*|\d{3})-?\d{3}-?\d{4}\s*$`)
var str = `(404) 666-1111
(404) 6661111
404-666-1111
404-6661111
404666-1111
4046661111
(404) 666-1111
(404)666-1111
404-666-1111
404-6661111
4046661111
+1 (404) 666-1111
( 404)666-1111
404.666.1111
404 666-1111
404 666 1111
(404-666-1111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}