import re
regex = re.compile(r"^\s*(?:\(\d{3}\)\s*|\d{3})-?\d{3}-?\d{4}\s*$", flags=re.MULTILINE)
test_str = ("(404) 666-1111\n"
"(404) 6661111\n"
"404-666-1111\n"
"404-6661111\n"
"404666-1111\n"
"4046661111\n"
" (404) 666-1111 \n"
"(404)666-1111 \n"
" 404-666-1111 \n"
" 404-6661111 \n"
" 4046661111\n\n\n"
"+1 (404) 666-1111\n"
" ( 404)666-1111\n"
"404.666.1111\n"
"404 666-1111\n"
"404 666 1111\n"
"(404-666-1111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")