#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\/\\\[\]:;|=,+*?<>\"\r\n\x80-\xff]*[A-Za-z]+[^\/\\\[\]:;|=,+*?<>\"\r\n\x80-\xff]*$"
Local $sString = "13221321778ok" & @CRLF & _
"ok2323" & @CRLF & _
"this(is)ok" & @CRLF & _
"underline_is_ok" & @CRLF & _
"point.isok." & @CRLF & _
"this space is replaced and ok" & @CRLF & _
"" & @CRLF & _
"thisandbelow+notallowed" & @CRLF & _
"21351" & @CRLF & _
"noµgood"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")