use strict;
my $str = '13221321778ok
ok2323
this(is)ok
underline_is_ok
point.isok.
this space is replaced and ok
thisandbelow+notallowed
21351
noµgood';
my $regex = qr/^[^\/\\\[\]:;|=,+*?<>\"\r\n\x80-\xff]*[A-Za-z]+[^\/\\\[\]:;|=,+*?<>\"\r\n\x80-\xff]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}