re = /^[^\/\\\[\]:;|=,+*?<>\"\r\n\x80-\xff]*[A-Za-z]+[^\/\\\[\]:;|=,+*?<>\"\r\n\x80-\xff]*$/m
str = '13221321778ok
ok2323
this(is)ok
underline_is_ok
point.isok.
this space is replaced and ok
thisandbelow+notallowed
21351
noµgood'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end