package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\/\\\[\]:;|=,+*?<>\"\r\n\x80-\xff]*[A-Za-z]+[^\/\\\[\]:;|=,+*?<>\"\r\n\x80-\xff]*$`)
var str = `13221321778ok
ok2323
this(is)ok
underline_is_ok
point.isok.
this space is replaced and ok
thisandbelow+notallowed
21351
noµgood`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}