const regex = /^[^\/\\\[\]:;|=,+*?<>\"\r\n\x80-\xff]*[A-Za-z]+[^\/\\\[\]:;|=,+*?<>\"\r\n\x80-\xff]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\\/\\\\\\[\\]:;|=,+*?<>\\"\\r\\n\\x80-\\xff]*[A-Za-z]+[^\\\/\\\\\\[\\]:;|=,+*?<>\\"\\r\\n\\x80-\\xff]*$', 'gm')
const str = `13221321778ok
ok2323
this(is)ok
underline_is_ok
point.isok.
this space is replaced and ok
thisandbelow+notallowed
21351
noµgood`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}