using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\/\\\[\]:;|=,+*?<>\""\r\n\x80-\xff]*[A-Za-z]+[^\/\\\[\]:;|=,+*?<>\""\r\n\x80-\xff]*$";
string input = @"13221321778ok
ok2323
this(is)ok
underline_is_ok
point.isok.
this space is replaced and ok
thisandbelow+notallowed
21351
noµgood";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}