import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\/\\\\\\[\\]:;|=,+*?<>\\\"\\r\\n\\x80-\\xff]*[A-Za-z]+[^\\/\\\\\\[\\]:;|=,+*?<>\\\"\\r\\n\\x80-\\xff]*$";
final String string = "13221321778ok\n"
+ "ok2323\n"
+ "this(is)ok\n"
+ "underline_is_ok\n"
+ "point.isok.\n"
+ "this space is replaced and ok\n\n"
+ "thisandbelow+notallowed\n"
+ "21351\n"
+ "noµgood";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}