using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[12]?\d{1,2}\.){3}[12]?\d{1,2}";
string input = @"127.0.0.1
192.168.101.100
255.255.0.0
....
1..0.1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}