import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[12]?\\d{1,2}\\.){3}[12]?\\d{1,2}";
final String string = "127.0.0.1\n"
+ "192.168.101.100\n"
+ "255.255.0.0\n\n"
+ "....\n"
+ "1..0.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}