package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[12]?\d{1,2}\.){3}[12]?\d{1,2}`)
var str = `127.0.0.1
192.168.101.100
255.255.0.0
....
1..0.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}