#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=6.1.1 Необходимые)([.*\w\W\n]+)(?=и чрезвычайных ситуациях)"
Local $sString = " 6.1.1 Необходимые Во время уборки используйте подходящие средства защиты и одежду. Не прикасаться к" & @CRLF & _
" действия общего поврежденным контейнерам или пролитому материалу, не надев соответствующей" & @CRLF & _
" характера при аварийных защитной одежды." & @CRLF & _
" и чрезвычайных ситуациях" & @CRLF & _
" 6.1.2 Средства Пользоваться непроницаемыми для пыли защитными очками, там, где существует" & @CRLF & _
" индивидуальной защиты опасность контакта с глазами. Надеть респиратoр с пылевым фильтрoм. Используйте" & @CRLF & _
" в аварийных ситуациях соответствующие химически стойкие перчатки. Обеспечить адекватную вентиляцию"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")