import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=6.1.1 Необходимые)([.*\\w\\W\\n]+)(?=и чрезвычайных ситуациях)";
final String string = " 6.1.1 Необходимые Во время уборки используйте подходящие средства защиты и одежду. Не прикасаться к\n"
+ " действия общего поврежденным контейнерам или пролитому материалу, не надев соответствующей\n"
+ " характера при аварийных защитной одежды.\n"
+ " и чрезвычайных ситуациях\n"
+ " 6.1.2 Средства Пользоваться непроницаемыми для пыли защитными очками, там, где существует\n"
+ " индивидуальной защиты опасность контакта с глазами. Надеть респиратoр с пылевым фильтрoм. Используйте\n"
+ " в аварийных ситуациях соответствующие химически стойкие перчатки. Обеспечить адекватную вентиляцию";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}