use strict;
my $str = ' 6.1.1 Необходимые Во время уборки используйте подходящие средства защиты и одежду. Не прикасаться к
действия общего поврежденным контейнерам или пролитому материалу, не надев соответствующей
характера при аварийных защитной одежды.
и чрезвычайных ситуациях
6.1.2 Средства Пользоваться непроницаемыми для пыли защитными очками, там, где существует
индивидуальной защиты опасность контакта с глазами. Надеть респиратoр с пылевым фильтрoм. Используйте
в аварийных ситуациях соответствующие химически стойкие перчатки. Обеспечить адекватную вентиляцию';
my $regex = qr/(?<=6.1.1 Необходимые)([.*\w\W\n]+)(?=и чрезвычайных ситуациях)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}