import Foundation
let pattern = #"(?<=6.1.1 Необходимые)([.*\w\W\n]+)(?=и чрезвычайных ситуациях)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
6.1.1 Необходимые Во время уборки используйте подходящие средства защиты и одежду. Не прикасаться к
действия общего поврежденным контейнерам или пролитому материалу, не надев соответствующей
характера при аварийных защитной одежды.
и чрезвычайных ситуациях
6.1.2 Средства Пользоваться непроницаемыми для пыли защитными очками, там, где существует
индивидуальной защиты опасность контакта с глазами. Надеть респиратoр с пылевым фильтрoм. Используйте
в аварийных ситуациях соответствующие химически стойкие перчатки. Обеспечить адекватную вентиляцию
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)