using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=6.1.1 Необходимые)([.*\w\W\n]+)(?=и чрезвычайных ситуациях)";
string input = @" 6.1.1 Необходимые Во время уборки используйте подходящие средства защиты и одежду. Не прикасаться к
действия общего поврежденным контейнерам или пролитому материалу, не надев соответствующей
характера при аварийных защитной одежды.
и чрезвычайных ситуациях
6.1.2 Средства Пользоваться непроницаемыми для пыли защитными очками, там, где существует
индивидуальной защиты опасность контакта с глазами. Надеть респиратoр с пылевым фильтрoм. Используйте
в аварийных ситуациях соответствующие химически стойкие перчатки. Обеспечить адекватную вентиляцию";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}