# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=6.1.1 Необходимые)([.*\w\W\n]+)(?=и чрезвычайных ситуациях)"
test_str = (" 6.1.1 Необходимые Во время уборки используйте подходящие средства защиты и одежду. Не прикасаться к\n"
" действия общего поврежденным контейнерам или пролитому материалу, не надев соответствующей\n"
" характера при аварийных защитной одежды.\n"
" и чрезвычайных ситуациях\n"
" 6.1.2 Средства Пользоваться непроницаемыми для пыли защитными очками, там, где существует\n"
" индивидуальной защиты опасность контакта с глазами. Надеть респиратoр с пылевым фильтрoм. Используйте\n"
" в аварийных ситуациях соответствующие химически стойкие перчатки. Обеспечить адекватную вентиляцию")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.