import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "===Substantiv===(.*(?:\\r?\\n(?!\\s*\\r?\\n).*)*)";
final String string = "===Substantiv===\n"
+ "Det var en gång en liten höna som gick på bio, fast det visste hon inte först.\n"
+ "Alltså visste hon inte.\n"
+ "Fast ändå var det ganska roligt för henne.\n"
+ " \n"
+ "==Annat==\n"
+ "Trots att det var roligt var det inte det.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}