const regex = /===Substantiv===(.*(?:\r?\n(?!\s*\r?\n).*)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('===Substantiv===(.*(?:\\r?\\n(?!\\s*\\r?\\n).*)*)', 'g')
const str = `===Substantiv===
Det var en gång en liten höna som gick på bio, fast det visste hon inte först.
Alltså visste hon inte.
Fast ändå var det ganska roligt för henne.
==Annat==
Trots att det var roligt var det inte det.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}