use strict;
my $str = '===Substantiv===
Det var en gång en liten höna som gick på bio, fast det visste hon inte först.
Alltså visste hon inte.
Fast ändå var det ganska roligt för henne.
==Annat==
Trots att det var roligt var det inte det.';
my $regex = qr/===Substantiv===(.*(?:\r?\n(?!\s*\r?\n).*)*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}