$re = '/===Substantiv===(.*(?:\r?\n(?!\s*\r?\n).*)*)/';
$str = '===Substantiv===
Det var en gång en liten höna som gick på bio, fast det visste hon inte först.
Alltså visste hon inte.
Fast ändå var det ganska roligt för henne.
==Annat==
Trots att det var roligt var det inte det.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);