import re
regex = re.compile(r"===Substantiv===(.*(?:\r?\n(?!\s*\r?\n).*)*)")
test_str = ("===Substantiv===\n"
"Det var en gång en liten höna som gick på bio, fast det visste hon inte först.\n"
"Alltså visste hon inte.\n"
"Fast ändå var det ganska roligt för henne.\n"
" \n"
"==Annat==\n"
"Trots att det var roligt var det inte det.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")